[OBIEE Issue] OBIEE 11g Deinstall Q&A

In order to get rid of the failed installation of the my last OBIEE 11G installation with the simple install. I performed the following tasks:( The reason that I did not use the uninstall wizard is there existed failure during my last installation and prevented the uninstall wizard from working correctly. I will cover the regular uninstall procedure after this.)

After that, I tired to install obiee 11g from the installation wizard again and when it came to the RCU configuration page.I encountered the following error:

INST-08020: One or more entries are found in HSS_COMPONENT table.
— A new schema must be used in order to install successfully.

Reason: When you conducted the simple install, you also had to point to the BIPLATFORM and MDS schemas. These schema tables get populated with the first installation attempt and succeeded. If you want to reinstall the software to enterprise install. You have to drop the BIPLATFORM and MDS Schemas created by the RCU install. Those schemas can only contain one OBI installation at a time unless you changed the prefix (ie: DEV_,QA_,PROD_,etc.) of the schemas if you had the RCU a second time against that same database.

Solutions: If you want to use the same database, then drop the schema firstly using the wizard and then manually delete the corresponding tablespaces. (ie: DEV_BIPLATFORM.dbf, DEV_MDS.dbf,etc)

Appendix: The regular uninstall procedure (Condition: Last install should be successfully completed)

1. Run the deinstall script and select the Deinstall instances managed by a WebLogic domain option.
* open terminal, go to /Oracle_BI1/oui/bin
* run deinstallation script:

$ ./runInstaller.sh -deinstall

1. Welcome
* next
2. Select Deinstallation Type
* select Deinstall ASInstances…
3. Specify Weblogic Domain Detail
* domain host:
* domain port: 7001
* username: weblogic
* password: weblogic1
4. Select Managed Instance
* select instance1, all become checked.
5. Deinstallation Summary
* save deinstallation configuration to: (You could save this information for debugging purpose)
* Deinstall
6. Deinstallation Progress
* no errors
7. Deinstallation Complete
* Success, click finish

* verify success of script by going to the instances folder and making sure it doesn’t contain the instances that were deleted

2. Stop all Oracle Business Intelligence processes and servers, including all OPMN-controlled components and JEE components.
* Go to http://:7001/em then click core application under the business intelligence folder. Stop the components.
* Components already stopped
3. Drop the Metadata Services (MDS) and Business Intelligence Platform (BIPLATFORM) schemas using RCU.
* on my desktop load the rcu: C:\ofm_rcu_win_11.1.1.5.0_disk1_1of1\rcuHome\BIN\rcu.bat
note: make sure all components are stopped otherwise errors will occur. opmnctl stopall
1. Welcome
2. Drop Repository
3. Database Connection Details
* database type: oracle database
* host name:
* port: 1521
* service name:
* username: sys
* password: *******
* role: sysdba
4. Select Components
* select DEV (note: it might be a different name according to your installation)from the drop down menu
* four check marks automatically on:
1. AS Common Schemas
2. Metadata Services
3. Oracle Business Intelligence
4. Business Intelligence Platform
* ok, ok
5. Summary
* drop
6. Completion Summary
* sucess, close
4. Run the deinstall script and select the Deinstall Oracle Home option.

$ cd /Oracle_BI1/oui/bin
$ ./runInstaller.sh -deinstall

1. Welcome
* next
2. Select Deinstallation Type
* select Deinstall Oracle Home…
3. Deinstall Oracle Home
* save response file to:(save to somewhere for further use, it is optional)
* deinstall
4. Deinstallation Progress
* yes, delete directory after deinstall
5. Deinstallation Complete
* finish

5. Deinstall the Oracle Common home manually or by running the deinstall script that it contains.

* If you installed Oracle Business Intelligence using the Simple or Enterprise Install type,
you can fulfill this requirement by specifying the JDK directory that was created by
Oracle Business Intelligence 11g Installer in the Middleware home.

$ cd /oracle_common/oui/bin
$ ./runInstaller.sh -deinstall -jreLoc /usr/java

1. Welcome
2. Deinstall Oracle Home
* save response file: (save to somewhere for further use, it is optional)
* deinstall
3. Deinstallation Progress
* yes to delete the directory after deinstall
4. Deinstallation Complete
* finish

6. Use the Oracle WebLogic Server uninstaller to uninstall WebLogic Server.

$ cd /wlserver_10.3/uninstall
run the shell script : /utils/uninstall/uninstall.sh

7. Remove the Middleware home (if necessary). If you have done enterprise install, then remove the foundation domain home as well.

* Delete all remainding files/directories

8 End of the instruction.

Advertisements

32 thoughts on “[OBIEE Issue] OBIEE 11g Deinstall Q&A

  1. Hi Claire

    Thanks for your sharing with details! We have encountered a stopper on Deinstalling the OBIEE instance from WL. (Deinstall v11.1.1.5 to upgrade to latest OBI version)

    In deinstall wizard step 4 of 7:
    4. Select Managed Instance

    We can only see “RemoteHost” with dimmed checkbox, so we cannot uninstall instance1 from WL. Can you give me some hints?

    Thanks
    Kenive

    1. Hi, Kenive
      It is hard to tell what was going on. First thing, let me ask you! Did you run the deinstaller from your localhost? If not, try to run the deinstaller from the server itself.
      So then when it comes to the 4th step, it would say localhost->instance1…
      Here are a few things I would check:
      1 Look into your instance folder, do you still see your instance1 over there? Someone might have already uninstalled the instances.
      2. Look into your deinstall log file which is under oraInventory/logs/deinstall-somedate.log. Check if there are any error messages that occured during the process.
      3. If none of the above would work for you, try to do what I did of cleaning the directories. That would also enable you for a brand new installation of the new version. But make sure you shut down all the processes related to the old version before you run the new installation.
      Let me know if that would help you!

      Best,

      Claire

      1. Thanks Claire for your prompt reply.
        Yes, we are running the deinstall from localhost.

        Finally we got the answer from Oracle SR with reference Doc:
        1324240.1 : Unable to Deinstall an Instance of Oracle Business Intelligence Enterprise Edition 11g

        It said we have to remove some problematic entries in Windows hosts file (C:\Windows\System32\drivers\etc), then it works and we move it back after deinstall. For your information, our server box has multiple network adaptor and may some entry added to hosts file after OBIEE install.

        Best Regards
        Kenive

  2. Hi

    I have got a requirement below.

    # Embed BI website into a web page using an IFRAME tag in HTML
    (Build a webpage and provide the links to BI Dash Board (16 reports))

    How to start and where to add the code and Is there any code available?

    Please help me out.

    1. Hi, Krishna
      I think it is not too hard to find the sample IFRAME HTML code to compose your webpage and dispatch the links.
      http://www.htmlcodetutorial.com/frames/_IFRAME.html

      Are you working with 10g or 11g BI reports? The second thing you need to do is to retrieve all the links to your dash boards.
      Check here to see how to compose the links to your dashboards:
      http://gerardnico.com/wiki/dat/obiee/dashboard_url

      Check here to see how to enable the bookmark links and prompted links:
      http://obiee101.blogspot.com/2008/12/obiee-creating-bookmark-and-or-prompted.html

      You could also use a link similar as below to directly access your bi dashboards if you know the locations of the reports in the catalog already.

      http://domain_name:portnumber/analytics/saw.dll?PortalPages&PortalPath=/shared/Standard%20Reports/_Portal/Sample%20Building%20Summary%20Report

      Note that: the special character %20 means space and you have to use the HTML hex character codes for any space occurring in your report name!
      Check here to see the conversion
      http://www.obkb.com/dcljr/charstxt.html

      Hope this would help!

      Claire

  3. Hi Claire. I recently “uninstalled obiee 11g on linux by deleting the Middleware directory and everything contained in it, deleted the oraInventory, and dropped the biplatform and MDS schemas. I then reinstalled but altered my directory stucture a bit. Originally it was: /u01/SOA/BISIT/Middleware….I deleted the SOA directory on forward and on reinstall, used /u01/BISIT/Middleware….everything installs fine but periodically, I notice that a new /u01/SOA/BISIT/instance1/ directory structure is created…if I delete it, it just reappears a short time later. Do you know what I might have missed that is periodically recreating the directory structure of this old instance? Thanks so much for your help!

      1. Hi Claire,

        Yes, after I read your article, I deleted the contents of my tmp directory but I also noticed that my MW_HOME variable was set to the old path! I went ahead and changed that as well and then started everything back up. It’s been running all day and the phantom instance directory has stopped appearing! woo hoo! Not sure which did the trick, but it appears to have worked! Thank you so much for your help and your quick response! 🙂

      2. Hi,Chris
        Good to hear you have resolved your issue! I am just curious if you are using windows platform?It was a good point you have just raised!

        Thanks!
        Claire

      3. Hi Claire!

        I installed it on a Linux 64 bit operating system. I’m in the process now of trying to integrate it with Oracle E-Business Suite. (fun fun!) Thanks again! Have a great evening!!!

        Chris

  4. Dropping schemas is not the only option. We can delete from the HSS_COMPONENT table too. The table exist for BIPLATFORM Schema user.

  5. Hi Claire,
    I deinstalled and re-installed the OBIEE11g BI under Windows XP on my laptop. Weblogic Server and Enterprise Manager is working fine. All services are up and running but I am unable to login to Presentation Service. I am getting the error that “wrong username and password”. I am getting the following errors in log:

    Component – AdminServer
    =====================
    Unable to initialize oracle.bi.security.service.SecurityWebService
    Error during initialization
    Unable to initialize oracle.bi.security.service.URIdentityStoreProvider

    Component – OBIPS
    ================
    Unable to create a system user connection to BI Server during start up. Trying again.
    odbc driver returned an error (SQLDriverConnectW)

    Could you guys please, help me as I am stuck here?

    Thanks,
    Abdul Moyeed

    1. Hi,Abdul
      Here are a few test cases you could try for me to gather more information of the behavior.

      1. Could not create a system user connection to Oracle BI Server during start-up. Please check the error message and try again.
      Authentication Failure.
      Odbc driver returned an error (SQLDriverConnectW).
      [nQSError: 10018] Access for the requested connection is refused.
      [nQSError: 43113] Message returned from OBIS.
      [nQSError: 43126] Authentication failed: invalid user/password.

      Try to look at your DB schemas/user MDS and BIPLATFORM to see if they got locked/ expired. It was a setting in Oracle DB which makes schemas or users lock after a period of time. You can use the following to unlock accounts:

      ALTER USER MDS ACCOUNT UNLOCK;
      ALTER USER BIPLATFORM ACCOUNT UNLOCK;

      If the password has expired make sure to revert it back to the password you used during installation. Use the following:

      ALTER USER MDS IDENTIFIED BY Admin123;
      ALTER USER BIPLATFORM IDENTIFIED BY Admin123;(Your password in this case)

      The above should do the trick if your issue is caused by DB users locked.
      2. If no 1 could not solve your problem, please provide the information for no 2-4!
      Try to use the client side BI administration tool to access your RPD. Were you able to do that using the same username/password set?
      3. When you firstly started the services from command line. You are prompted to input the username and password. Did you encounter with any error messages after that?
      4. Take a look at files : NqsConfig.ini and instanceconfig.xml. Did you see any changes over there?

      Let me know if have solved the problem and good luck!

      Best,
      Claire

      1. Also there could be mismatch between BISystemUser password in console and em.
        Making them same may help as we had similar issue once. Don’t use any special characters in these passowrds.

  6. I tried to deinstall in the frontend, however, I cannot get through the “Specify WebLogic Domain Detail” step. I got error: “INST-07242 Unable to connect to Oracle Weblogic Administration Server”. I think that my Oracle Weblogic Administration Server is not up because I cannot display the page “http://localhost:7001/console/”. I tried to StartWeblogic by running the following:

    C:\middleware\user_projects\domains\bifoundation_domain\bin>startWebLogic.cmd

    But I got “Authentication for user WebLogic denied”

    I also tried the following:
    C:\middleware\user_projects\domains\bifoundation_domain\bin>StartManagedWebLogic.cmd bi_server1 http://localhost:7001

    I got “The server name bi_server1 specified with -Dweblogic.Name does not exist. ”

    Should I deinstall manually instead of deleting the directories, can I rename the following directories (delete them afterward) intead:
    c:\middleward (i.e. the whole middleward directories)
    c:\bea
    c:\Program Files\Oracle (is this your oraInventory? I cannot find oraInventory)
    c:\temp

    Then drop the BIPLATFORM and MDS Schemas using RCU and create it again with another prefix.

    Do you think this is a good plan? Or any other suggestions?

    1. You could rename the directories by not deleting them. But I felt it was not that necessary to keep those dirs. My initial goal of the experiment is to make a clean removal of the old data.The Oracle Inventory directory (oraInventory) stores an inventory of all software installed on the system. So it might remember your last installation parameters that prohibit you from a fresh new installation. The bea folder contains the path for the last installation middleware home. Did you lose the password for your login credentials according to the error msg”Authentication for user WebLogic denied”

      If that is the case, you might consider restore your password firstly. I was also tried to uninstall obiee11g by using the GUI they provided. But I figure it would be more complex that way.Let me know what you think.

  7. I’ve learn some just right stuff here. Definitely value bookmarking for revisiting.

    I wonder how so much attempt you place to create
    such a fantastic informative site.

  8. hello!,I like your writing so so much! propotion we
    keep in touch extra approximately your article on AOL?

    I need an expert on this house to solve my problem. May be tthat is you!
    Having a look forward to peer you.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s